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= Data Browser Perspective

Data Browser Perspective Structure

Data Browser

The Data Browser Perspective holds a central place in Velo for managing datasets. Direct access to the perspective is provided on
both the @ Home Screen, as well as on the Perspective Short Cut Bar (labelled Data Browser). The Data Browser Perspective is

by default organized into six main views (Figure 1):

= Data Browsing View
i Folder Contents View

=] Preview View

= Summary View
% Search Results View

@ Resource Web Page

Each of these Views are described in the following sections.
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Figure 1. Data Browser Perspective Structure.

= Data Browsing View

Whe_n the Data Browser perspective is opened, the directory tree structure appears in the Data Browsing View (Figure 1), under
the & Repository directory. The Repository directory is divided into two folders: the Team Documents Folder and the User

Documents Folder.

In the Team Documents folder, subfolders are created for each team the user belongs to and are preceded by the team folder icon
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.
In the User Documents Folder, the directory tree structure is displayed for both shared and private user workspaces. Shared

workspace are indicated with the ¥ icon while private workspace are preceded by the % icon (Figure 1).

¥ Private user workspaces are visible under Users Documents only if users give permissions to
see their home folder.

Permissions can be modified by right-clicking on the home folder name, and selecting
Properties>Permissions.

A user can create any number of folders and even store folders inside other folders (subfolders) in order to organize his work.
Folders are shown with the T icon. It is important to differenciate a basic folder ) from a Dataset folder ®. Unlike a basic
folder, when a dataset is created the user is given tools to prepare the dataset to be published.

8 Note that the Dataset Publishing Process is described in details in the XXXXX section.

Favorites

The Favorites section of the view provides a serie of shortcuts that are shown in the top section of the Data Browsing View
(Figure 1). Favorites may be an important feature especially when working on several research projects and/or a broad list of
folders and files.

Adding new shortcuts in the Favorites folder can be done in multiple ways. One way is to drag a selected item to the Favorites
section, another is to copy and paste an item from the directory tree to the Favorites folder

&¥ Smart Folders

Need to add explanation

== Categories

Need to add explanation

© Folder Contents View

The Folder Contents View provides the detailed list (e.g, name, type, size, date of creation) of files included under the item
highlighted in the Data Browsing View.

Summary View

The Summary View provides detailed information regarding the item selected in the directory tree structure (Figure 1, [1]). The
Summary View will always provide general information including the path of the file, the author, the date of creation or date of
modification of an item.

Z1Preview View

This pane shows a preview of the file (text or image) selected in the Folder Contents View (Figure 1, [2] and Figure 2).
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Figure 2. Preview of an Image File and a Text File in the Preview View

Right-click in the Preview Pane and choose Find... from the pop-up menu to
see a Find dialog for entering a search query and finding it in the preview

display.

< Search Bar and Search Result View

When browsing through numerous files and folders, getting lost inm the directory tree structure may be easy. The path bar located
at the topo of the perspective allows the user to know where the file or folder selected is located (Figure 1) . From this location,

the user is given the possibility to search data using the Search bar (Figure 1).

The Search option searches the documents to which the user has authorized access. This includes all documents, folder names and
file names.When the Seach is completed, the Search Results View lists documents found by the search.

@ Resource Web Browser View

The Resource Web Page view shows users web pages that are associated with the selected W dataset. Several web pages are
associated to a single resource, each related to a category of information a user has to provide for the selected dataset (Figure 3):

Overview
Data Access
Metadata

Publications Contacts info

Related Websites
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Carina's Cats

The domestic cat[1)[2] (Felis catus or Felis silvestris catus)[2][4] is a small, usually furry,
domesticated, and camivorous mammal. They are often called housecats when kept as
indoor pets or simply cats when there is no need to distinguish them from other felids
and felines.[6] Cats are often valued by humans for companionship and their ability to
hunt vermin.

Show more

Bucket

Mr. Magnificent

Figure 3. Resource Web Browser View Example.

First Steps of Data Management in Velo
The Data Browser perspective offers efficient tools to manage and organize documents and datasets.

Creating a New folder

A user can create any number of folders and even store folders inside other folders (subfolders). To create a new folder, highlight
in the directrory tree the item where the new folder is to be located, two ways are possible:

1. Select File> T¢New Folder;
2. Right-click on the item where the new folder is to be created and select ¢ New Folder.

A window will pop up so that the new folder name can be entered (Figure 4).

.
%74 Creating folder in /User Documents/Delphine/Project ALPHA [

Folder Name:

Figure 4. New Folder Name Window.

Creating a New Dataset

To create a new dataset, right-click on the item where the dataset is to be created in the directory tree and select @ New Dataset. A
new window will pop-up (Figure 5), requesting the user to provide a Name for the dataset folder that will be disaplyed in the
directrory tree, and also at Title for the dataset. The dataset Title is intended to include more details regarding the dataset. The
owner of the dataset can set permissions to new users/teamsby clicking on the Add button (see Setting Permissions).
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When cliking on Finish, the Dataset Editing perspective will pop-up, allowing the user to prepare the dataset to be published. A

Data Browser

3 New Dataset . New Dataset Window

Dataset Folder Name:  Arsenic Concentration

Dataset Title: Arzenic Concentration in OL-14 Unit

Owner: Delphine (only owners or admin can change permissions)

Destination:  jcer Documents/Delphine/100-0L-1 O

Mame Permission Level

Permission Level:

Finish

J{

Cancel

Figure 5. New Dataset Window.

step by step help is provided.

Importing Data

Data can be imported from local machines, or remote servers to a selected destination .

To import data, highlight the destination folder. Two options then follow:

1. Select File > fﬂ]mport Files
2. Right-click on the destination item in the directory tree and select & Import Files.

An Import Files window will pop up. From this window, the user can change the destination by clicking Browse and can select the
file(s)/folder(s) to be imported by clicking on Select files... . A new window opens and the user is given the option to navigate in
the local machine or remote servers and select the items to be imported by using the checkboxes (Figure 5).

If running Velo on a Windows machine, files from the Windows File Explorer

can be copied to Velo by dragging them to Velo's directory tree.
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Data Browser

3% Import Files L e —

Import Files Window

[

Import Files

Select a folder from the local file system to import. Data will be imported and properties
will be extracted and added as metadata.

Destination: /User Documents/Delphine/100-OL-1 Operable Unit Pilot Stus

Files to Import:

From Machine Total Size of Data Import Acti

Ef Local 1 files /1 folders / 484 KB

< | m 3

< Back Next > Finish

Exporting Data

It is also possible to export data located in Velo (in shared or Private Workspaces) to a local machine.

Figure 6. Import Files Window.

To accomplish the data export, two options are available:

1. Select File> Export Files

2. Right-click on the resources to be exported in the directory tree and select & Export Files.

The File Export Wizard window will pop up, allowing the user to select both the items to be exported and the destination folder.

Cut, Copy and Paste Options

Basic functions such as copy, cut and paste file(s) or folder(s) are also available in the Data Browser perspective.

These options are accessible when right-clicking on a item.

Setting Permissions

Permissions for files, folders and datasets can also be set within Data Browser Perspective (Figure 7, [1]). The user can assign

different levels of permissions fo

e Coordinator
o Read all items
o Create new items
o Edit all items
o Delet all items
e Collaborator
Read all items
Create new items
Edit all items

o

O O o

e Contributor
o Read all items
o Create new items
o Edit items they own

r either a single user, or a team (Figure 7, [2]):

Delete items they own
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o Delete items they own

e Consumer
o Read all items

Data Browser

The rights allowed for each category are displayed when selecting the permission type.

-
%73 Belection Usefs or Groups Lilﬂu
Teams | Users

Select users from the left, click the '>>' button to allow them access.
Remove access by selecting users on the right and clicking the "< <' button.

Available Users Allowed Users

type filter text 1 & Lansing, Carina

& Appriou, D e

& Beecher,

| & Day, Justin

& Guillen, Zoe

& Jackson, Mike

& Sivaramakrishnan, Chandrika

Properties for Arsenic Concentrati .lglﬂlg
ﬁ roperties Tor Arsenic ncentration . =
[type filter text Permissions PYTD Y
Resource |
Permissions Owner: Delphine (only owners or admin can change permissions)
Name Permission Level
Justin Day Coordinator
[ Carina Lansing Consumer
||
(|
I
||
~
(|
: Permission Level: 2 i v
Ll

Read all items.
Create new items.
Edit all items.
Delete all items.

L L N

Other Views

Data Browser perspective can be customized with other views that might be useful when working with Velo. Two views that may

be commonly used are the

o [Scratch Pad View
e '“/Comments View

Figure 7. Setting Permissions

To open these views, select Window>Open View and select the View to open.

[ Scratch Pad View

This View provides a utility for comparing two different files. This isuseful for identifying differences between individual text

files.
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To open the Scratch Pad View, select Window>Open View> Scratch Pad. This will launch the Scratch Pad viewer, which will be
placed in the bottom right hand corner of the perspective.

To compare two different text files, the following operations are required:
1. Navigate to the location of the files within the directory structure. Drag the files to the Scratch Pad.
2. Highlight both files; control-click in Windows, command-click in Mac. Once both files are highlighted, right click and

choose Compare with Each Other. The files will appear side-by-side in the Preview Pane. Differences in the files will be
highlighted.

“ Comments View
The Comments View allows one or several users to leave written comments for the selected item in the directory tree.

To open the Comments View, select Window>Open View> Comments. To add a comment, click on the “# icon.

The comments can be edited by clicking on ? or deleted by clicking on %,

Note that comments can only be displayed when the Comments View is active
in the perspective.

Access to Other Perspectives Help

® 758 > T

Dataset Remote
Home Editin Users || Teams ||Search || System
Zdiling Explorer
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